Network Degradation - US-E Region

Minor incident Global Network and Backbone North America - East
2026-08-26 14:29 UTC · 2 hours, 13 minutes, 1 second

Updates

Resolved

This incident has been fully resolved. The impacted hardware has been fully tested, monitored for one hour and brought back into service restoring the Ashburn, VA POP to full operational capacity from N to N+1.

If you are experiencing any issues at all, please open a support case at https://support.totaluptime.com.

August 26, 2026 · 16:37 UTC
Update

The issue has been identified as a hardware failure in the Ashburn, VA POP. Any customer traffic traversing the device at the time of the failure was automatically rerouted to alternate devices within that POP and/or alternate neighboring POPs.

If you are experiencing any issues, please open a support case at https://support.totaluptime.com.

We will update this case once restoration is complete.

August 26, 2026 · 14:36 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss in the US-E region. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

August 26, 2026 · 14:29 UTC

← Back