Network Degradation
Minor incident
Global Network and Backbone
North America - East
Europe
2026-05-13 15:08 UTC
· 23 minutes
Updates
Resolved
May 13, 2026 · 15:29 UTC
We confirm that this issue has been fully resolved at 15:09 UTC and there are no further impacts seen since our corrective actions were taken.
Update
May 13, 2026 · 15:10 UTC
Engineers have resolved an upstream provider issue and have redirected traffic at this time. We are monitoring to confirm stability.
Issue
May 13, 2026 · 15:08 UTC
We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.
← Back
Total Uptime Status