Support Panel Access Issues

Minor incident Support Ticket System
2025-11-11 15:29 UTC · 48 minutes

Updates

Resolved

This issue has now been resolved.

November 11, 2025 · 16:17 UTC
Issue

We are currently investigating an issue affecting access to the Support Panel from some regions. As soon as we have further information to share, we will update you.

November 11, 2025 · 15:29 UTC

← Back