Partial platform access issues

Minor incident Totaluptime.com website Support Ticket System
2025-09-10 14:50 UTC · 8 minutes

Updates

Resolved

Engineers found an internal load balancing issue and have resolved it. We are currently investigating for a root cause to determine why this happened. However we are resolving this incident since it is no longer customer impacting.

September 10, 2025 · 14:57 UTC
Issue

We are currently investigating an issue affecting access to the Total Uptime website and support panel from some regions. As soon as we have further information to share, we will update you.

September 10, 2025 · 14:50 UTC

← Back