Network Change Propagation Delay - US-E region

Minor incident Cloud Load Balancing ADC-as-a-Service Web Application and API Protection (WAAP) Global Network and Backbone North America - East
2025-03-14 14:02 UTC · 1 hour, 49 minutes

Updates

Resolved

This issue has now been fully resolved. All updates are successfully processing to all US-E nodes at this time.

March 14, 2025 · 15:52 UTC
Update

Engineers have implemented a fix and we are now waiting for all pending updates to clear the queue for this node in the US-E region.

We will update this case as soon as we have confirmed all queued updates have completed successfully and everything has returned to normal.

March 14, 2025 · 15:28 UTC
Update

We have confirmed that updates are delayed to a single node in the US-E region. This node has been taken out of service to prevent impact to customer traffic, however, updates will appear to remain queued for the US-E region in general even though all other nodes are accepting and completing updates normally.

Because we have taken the affected node out of service, customer traffic is not affected by this issue. This is now essentially a display issue within our UI, albeit an annoying one.

Please accept our apologies for the continued delay in resolving this and rest assured that all changes are otherwise completing successfully across our platform despite potentially incorrect device status and/or completion messages for the US-E region.

As soon as we have further updates, we will post them here. We anticipate this issue to be fully resolved within another 30 minutes.

March 14, 2025 · 14:35 UTC
Update

Engineers have identified this issue with our update orchestrator. We are working diligently to resolve this as quickly as possible.

March 14, 2025 · 14:27 UTC
Issue

We are currently investigating delays with Network change propagation to devices in the US-E region. Changes made in our UI or via our API are taking longer than expected to push to all devices in this region. Engineers are aware of this issue and are working to resolve it as quickly as possible.

March 14, 2025 · 14:02 UTC

← Back