Network Degradation - Europe

Major incident Cloud Load Balancing ADC-as-a-Service Global Network and Backbone Europe
2025-02-25 03:10 UTC · 47 minutes

Updates

Resolved

All traffic levels, latencies and other monitored metrics have returned to normal levels across Europe at this time.
While we are marking this incident as resolved since it should no longer be customer impacting, we are continuing to investigate this further since our time to resolution was unsatisfactory.

February 25, 2025 · 03:57 UTC
Update

Network operations confirm losing 2 x 100Gbps links across our backbone. This has caused congestion and latency as routes re-converge across alternate paths. Traffic is currently returning to normal, but may take a few more minutes to fully stabilize.

February 25, 2025 · 03:15 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

February 25, 2025 · 03:10 UTC

← Back