Network Degradation

Major incident Global Network and Backbone Europe
2024-11-21 15:58 UTC · 1 hour, 37 minutes

Updates

Resolved

This issue has been resolved and after monitoring for 30 minutes, we do not find any further issues.

November 21, 2024 · 17:35 UTC
Update

Onsite engineers in our Amsterdam POP have identified a failed PDU in one of our networking racks which caused a cascading failure for a few critical devices in that rack. This has been replaced and affected systems are coming back online. Further details will be provided as soon as they are available.

November 21, 2024 · 16:49 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in Europe. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

November 21, 2024 · 15:58 UTC

← Back