Network Degradation in Europe

Minor incident Global Network and Backbone Europe
2024-09-24 23:07 UTC · 3 hours, 26 minutes

Updates

Resolved

This issue has been resolved and full redundancy across our backbone between Amsterdam and London has been restored.

We are now resolving this incident.

September 25, 2024 · 02:32 UTC
De-escalate

We can confirm that all traffic levels continue to show normal at this time. We are downgrading this incident from major to minor while we await updates from our providers regarding the outages. All traffic engineering is complete.

We will provide further updates here as they become available.

September 24, 2024 · 23:48 UTC
Update

At 23:00 UTC exactly, we lost two of our three backbone links between London and Amsterdam. This caused contention on the remaining link. Engineers performed traffic engineering to balance traffic via alternate paths to mitigate this issue. All 3 links are served by separate fiber providers and diverse paths. We are currently working with the two affected fiber providers to understand the root cause of this issue and will provide further updates here as they become available.

September 24, 2024 · 23:30 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in Europe. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

September 24, 2024 · 23:00 UTC

← Back