Network Degradation in Europe

Minor incident Global Network and Backbone Europe
2023-08-25 00:30 UTC · 21 minutes

Updates

Resolved

This issue has been resolved. Our provider has confirmed a fiber connection event between Amsterdam and London that has since restored. Traffic is currently flowing via our alternate path at this time and no further events are anticipated at this time.

August 25, 2023 · 00:50 UTC
Update

Engineers have confirmed a link failure in our backbone between Amsterdam and London. Traffic failed over to our alternate link within 30 seconds and service is normalizing at this time. We are currently investigating the failure and will provide further updates as they become available, however no further impact should be seen at this time.

August 25, 2023 · 00:33 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in Europe. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

August 25, 2023 · 00:30 UTC

← Back