Network Degradation US-W

Minor incident Global Network and Backbone North America - West
2023-07-21 11:31 UTC · 26 minutes

Updates

Resolved

Our engineers have confirmed an issue on the Cogent network that caused these issues. Since the issue has resolved, we have reached out to them for additional information regarding the event we observed.

July 21, 2023 · 11:57 UTC
Monitoring

This issue appears to have cleared, however we are investigating suspected network provider issues or undisclosed maintenance activities in the region that are beyond our network.

July 21, 2023 · 11:48 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in the US-W region. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

July 21, 2023 · 11:31 UTC

← Back