Network Degradation in Europe

Minor incident Global Network and Backbone Europe
2023-01-05 23:06 UTC · 3 hours, 34 minutes

Updates

Resolved

It has been over 3 hours since this incident and all circuits have been restored and confirmed stable. We are now resolving this incident.

January 6, 2023 · 02:40 UTC
De-escalate

Traffic has normalized at this time and latency has returned to acceptable levels. We are continuing to monitor for any further issues not resolved by automation.

January 5, 2023 · 23:25 UTC
Update

Network engineers have confirmed that one of our largest upstream providers out of Amsterdam is currently down. Traffic has rerouted to alternate providers as well as across our backbone to other POPs. Unfortunately the BGP churn as a result of a major link loss can take a few minutes to normalize.

January 5, 2023 · 23:11 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in Europe. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

January 5, 2023 · 23:06 UTC

← Back