Europe Network Degradation

Minor incident Global Network and Backbone Europe
2020-04-02 15:17 UTC · 29 minutes

Updates

Resolved

We have observed no further issues within the region and are considering this incident resolved. Pending updates from the carriers, we will restore connectivity to them at a later time.

November 4, 2021 · 15:24 UTC
Monitoring

Networks have normalized within the region after the removal of TATA and TELIA. Engineers are continuing to monitor. We are also waiting for further information from these providers regarding the incident to determine if they have resolved the root cause.

November 4, 2021 · 15:24 UTC
Investigating

Engineers have pulled all traffic from TATA and TELIA within the region and are continuing to monitor network performance via alternate paths.

November 4, 2021 · 15:24 UTC
Investigating

It appears that providers TATA and TELIA are currently exhibiting high latency and packet loss on their links within the region. Engineers are working to get around these provider issues.

November 4, 2021 · 15:24 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in Europe. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

November 4, 2021 · 15:24 UTC

← Back